Ayah Wiki
Advertisement

Начало[]

en

самая главная команда, включает права на редактирование.

configure terminal

заходим в режим конфигурации, все операции из этого режима.

hostname Switch0

задаем имя узлу.

enable secret cisco

задаем пароль на доступ к узлу.

Привязка vlan'у адреса/маски[]

interface vlan 1

заходим в настройки vlan 1

ip address 192.168.10.254 255.255.255.0

назначаем адрес/маску

no shutdown

включаем

Задание коммутатору шлюза по умлочанию[]

ip deafult-gateway 192.168.10.1

Прописывание секурности[]

line con 0
password cisco
login
line vty 0 4
login
password cisco

Привязка порта к vlan[]

interface fastethernet0/1

выбор интерфейса

switchport mode access

???

switchport access vlan 99

привязка к vlan 99 руками

no shutdown

включаем

Смена приоритета span[]

show spanning-tree
spanning-tree vlan 1 priority 4096

Настройка магристрали[]

interface FastEthernet0/1
switchport mode trunk
switchport trunk native vlan ##
show interfaces trunk

Создание VTP[]

vtp domain Trololo

создаем VTP с именем Trololo

vtp mode

(server - сервер / client - полносьбю зависим от сервера / transparent - независимый, но передает траффик от / к завяисимых)

vtp password <password>

задаем пароль

set vtp pruning enable

не срет инфой о vlan'ах, туда где их нет

show vtp status

смотрим состояние.

Краткая информация по интерфейсам[]

show ip interface brief

Привязка к интерфейсу адреса/маски[]

interface FastEthernet0/0

заходим в интерфейс

ip address 192.168.12.1 255.255.255.0

присваиваем адрес и маску

no shutdown

включаем

Создание inter-vlan маршрутизации[]

Router[]

interface FastEthernet0/0

создаем интерфейс

no shutdown

включаем

interface FastEhtenet0/0.10

создаем под-интерфейс

encapsulation dot1q 10

указываем, что будет принимать vlan 10

ip address 192.168.10.252 255.255.255.0

задаем адрес под-интерфейса

interface FastEhtenet0/0.20

создаем под-интерфейс

encapsulation dot1q 20

указываем, что будет принимать vlan 20

ip address 192.168.20.252 255.255.255.0

задаем адрес под-интерфейса

Switch[]

vlan 10

создаем Vlan 10

vlan 20

создаем Vlan 20

interface FastEthernet0/1

создаем порт - к ПК1

switchport mode access

???

switchport access vlan 10

привязываем его к Vlan 10

interface FastEthernet0/2

создаем порт - к ПК2

switchport mode access

???

switchport access vlan 20

привязываем его к Vlan 20

interface FastEthernet0/10

создаем порт - к Router1

switchport mode trunk

указываем что порт будет транком

switchport trunk allowed vlan all

пропускать будет все vlan'ы

IP-192.168.10.1 Шлюз ПК1 = R1-Fa0/0.10-192.168.10.252
IP-192.168.20.1 Шлюз ПК2 = R1-Fa0/0.20-192.168.20.252

Создание RIP маршрутизации[]

router rip

включаем

version 2

более понтовая

network 192.168.1.0

добавляем сети на интерфейсах

show ip protocols

проверяем настройки

no auto-summary

отключаем автосуммирование

ip route 0.0.0.0 0.0.0.0 s0/0/1

отправляем остатки на s0/0/1

default-information originate

сообщает об этом всем

passive-interface

отключаем обновление маршрутов для тупика

Создание EIGRP маршрутизации[]

router eigrp 100

включаем маршрутизацию, где 100 ее номер

network 192.168.1.0 [wildcard mask]

добавляем сети

no auto-summary

Создание OSPF маршрутизации[]

router ospf 1
network 192.168.1.128 0.0.0.63 area 0

wildcardmask номер зоны

network 192.168.15.0 0.0.0.3 area 0
ip ospf priority

смена приоритета

log-adjacency-changes

информация о установке соседства

show ip ospf neighbor

показывает соседей

show ip ospf neighbor detail

детально по каждому соседу

no router ospf 1

стираем

Приоритет чем выше тем круче

DR - Designated router

BDR - Backup Designated router

DROther - other DR

interface loopback 0
ip address 10.0.1.1 255.255.255.255

создаем loopback 0

interface fa0/0
ip ospf priority 25

меняем приоритет

interface se0/0/0
bandwidth 64

меняем полосу пропускания, дабы изменить понтовость маршрута

interface se0/0/1
ip ospf cost 2000

меняем стоимость маршрута

default-information originate

рассказать всем о 0.0.0.0 маршруте

Создание ACL[]

Standart[]

ip access-list standard File_Server_Restrictions

создаем лист с именем

deny 192.168.20.0 0.0.0.255

запретить этим лохам

deny host 192.168.10.3

запретить этому лоху

permit any

разрешить остальным

interface fastethernet 0/1.1

выбираем интерфейс

ip access-group File_Server_Restrictions out

приземляем ACL-лист на исх. траффик

Extended[]

access-list 100 permit tcp any host 10.10.10.254 eq 80

разрешить по tcp всему на 10.10.10.254 по порту =80

access-list 100 permit udp any host 10.10.10.250 eq 53

разрешить по udp всему на 10.10.10.250 по порту =53

access-list 100 deny ip any any

запретить по ip всему ко всему

interface fa0/0

выбираем порт

ip access-list 100 out

приземляем на порт ACL-лист 100 на исх. траффик

Advertisement