Ayah Wiki
Advertisement

Создание loopback[]

interface loopback 0

ip address 10.250.4.1 255.255.255.0

no shutdown

Создание DHCP[]

DHCP для телефонна[]

ip dhcp POOL 7940
network 10.3.2.0 255.255.255.0

указываем пул ip-адресов

default-router 10.3.2.101
exit
ip dhcp excluded-address 10.3.2.101
ip dhcp POOL 7940
option 150 ip 10.3.2.101
domain-name ctc

DHCP для РС[]

ip dhcp pool PC
default-router 10.3.3.1
exit
ip dhcp excluded-address 10.3.3.1

Создание DN[]

Основное[]

ephone-dn 1 dual-line

создаем двух-линейный DN

number 4001 secondary 4002

назначаем номер (первичный и вторичный)

label Line1

устанавливаем название линии

name ayah 1

устанавливаем имя

preference 0

устанавливаем приоритет (0 - самый высокий)

Переадресации[]

call-forward busy 4003

переадресация по занято на 4003

no call-forward busy

снятие переадресации по занято

call-forward noan 4003 timeout 5

переадресация по неответу через 5 секунд

no call-forward noan 4003

снятие переадресации по неответу

Прочее[]

no huntstop

при звонке из внешней сети, не посылает сигнал "занято", а продолжает искать DN, при условии, что один DN висит на нескольких линиях.

caller-id block

антиАОН (не шлет ни имени ни DN)

no caller-id block

снятие антиАОНа

Создание Ethernet-Phone[]

ephone 1

создаем ephone под номером 1

mac-address 001A.924E.FECA

привязываем к нему мак-адрес

button 1:1

назначаем на первую кнопку ТА DN=1 (кнопка:DN)

type 7940/CIPC

задаем тип TA (для физических ТА Cisco задание типа не обязательно)

Глобальные настройки сервера[]

telephony-service

входим в настройки

directory entry 1 4001 name Ayah1

создаем запись в телефонной книге под номером 1 с именем Ayah1 и номером 4001

user-locale ru

подгрузка русской локализации на ТА

network-locale ru

подгрузка русских стандартов сигналов

date-format dd-mm-yy

формат даты дд-мм-гг

time-format 24

формат времени 24 часа

time-zone 32

установка тайм-зоны - Россия

system message Site4

светит на ТА имя сервера

Исходящая маршрутизация[]

interface loopback 0

заходим в интерфейс loopback 0

h323-gateway voip interface

делаем его h.323-gateway

dial-peer voice 3 voip

создаем dial-peer=3

destination-pattern 300.

номера формата 300х

session target ipv4:10.250.3.1

отправляем на IP-адрес

Digits Manipulation - цифирные манипуляции[]

Rules - правила[]

voice translation-rule 1

создаем правило №1

rule 1 /^4001/ /74956664001/

меняем 4 цифры на 11 цифр


voice translation-rule 2
rule 2 /^97495/ /7495/


voice translation-rule 3
rule 3 /^98495/ /7495/


voice translation-rule 4
rule 4 /^7495/ /98495/


voice translation-rule 5
rule 5 /^7495666/ //


test voice translation-rule 5 74956664009
Matched with rule 5
Original number: 74956664009    Translated number: 4009
Original number type: none      Translated number type: none
Original number plan: none      Translated number plan: none

Profiles - профили[]

voice translation-profile voip-out

создаем профиль с именем "voip-out"

translate calling 1

номер А по правилу 1

translate called 2

номер Б по правилу 2


voice translation-profile voip-out2

создаем профиль с именем "voip-out2"

translate calling 1

номер А по правилу 1

translate called 3

номер Б по правилу 3


voice translation-profile voip-in

создаем профиль с именем "voip-in"

translate calling 4

номер А по правилу 4

translate called 5

номер Б по правилу 5

Dial-peers[]

dial-peer voice 10 voip

создаем dial-peer №10

translation-profile outgoing voip-out

применяем профиль "voip-out" на исходящий вызов

destination-pattern 974951234567

условие срабатывания dial-peer исх. вызов на 974951234567

session target ipv4:10.250.250.101

куда отправляем такой вызов


dial-peer voice 15 voip

создаем dial-peer №15

translation-profile outgoing voip-out2
destination-pattern 984951234567

условие срабатывания dial-peer исх. вызов на 984951234567

session target ipv4:10.250.250.101

куда отправляем такой вызов


dial-peer voice 16 voip

создаем dial-peer №16

translation-profile incoming voip-in

применяем профиль "voip-in" на входящий вызов

incoming called-number 7495666400.

условие срабатывания dial-peer - входящий номер Б

Hunting[]

ephone-hunt 1 sequential

создаем хант-группу с номером 1

pilot 4009

задаем пилотный номер

list 4001, 4002

создаем список номеров в группе

final 4003

задаем конечный номер, на котором останется номер

timeout 2

тайм-аут перехода при неответе

Запрет звонков на направления[]

Всем[]

after-hours block pattern 1 1555.T

на номера 1555ххх

after-hours date May 23 00:00 23:59

23го мая весь день

after-hours override-code 1234

дозвониться можно только с оввер-райд кодом 12341555ххх

Диал-пиру[]

dial-peer voice 12 voip
paramspace callsetup after-hours-exempt true

добавляем разрешающее правило данному диал-пиру.

SIP[]

sip-ua

заходим в глобальные настройки сипа

authentication username ayah password 7 0607162044

прописываем пользователя

registrar ipv4:10.250.4.1 expires 3600

указываем адрес где будут регаться пользователи

sip-server ipv4:10.250.3.1

прописываем сип-сервер, куда отпра


dial-peer voice 3 voip

создаем диал-пир №3

destination-pattern 300.

номер Б 300х

session protocol sipv2

прокол sipv2

session target sip-server

запрос отправляем на sip-server

XXX[]

interface Loopback0

заходим в интерфейс

ip address 10.250.4.1 255.255.255.0

назначаем адрес

h323-gateway voip interface

делаем его h323 шлюзом

h323-gateway voip id ZONE_SITE-4 ipaddr 10.250.250.101 1719

регаем id ZONE_SITE-4 на адресе 10.250.250.101 (10.250.250.101 - Gatekeeper)

h323-gateway voip h323-id GW-4

присваиваем h323-id

h323-gateway voip tech-prefix 1#

присваиваем тхнический префикс для выхода на Gatekeeper

h323-gateway voip bind srcaddr 10.250.4.1

указываем исходный адрес h323-шлюза

Advertisement